Back to the main page

Cisco Catalyst 4948E-F switch setup

 Connect to Catalyst serial console and power on the device. 
See the initial configuration.
#  show running-config 
Building configuration...
Current configuration : 3871 bytes
!
! Last configuration change at 17:30:26 GMT Wed May 13 2015
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch

Setup hostname, domain, name server, timezone.
Switch#  config t 
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)# hostname room-8switch1

room-8switch1(config)# ip domain-name us.etcfstab.com

room-8switch1(config)# ip name-server x.x.x.x
room-8switch1(config)# ip name-server y.y.y.y

room-8switch1(config)# clock timezone UTC 0

room-8switch1(config)# end

room-8switch1#write memory
Building configuration...
Compressed configuration from 3996 bytes to 1520 bytes[OK]

Setup Management interface.
room-8switch1#config t
Enter configuration commands, one per line.  End with CNTL/Z.

room-8switch1(config)#interface FastEthernet1

room-8switch1(config-if)#ip address ?
  A.B.C.D  IP address
  dhcp     IP Address negotiated via DHCP
  pool     IP Address autoconfigured from a local DHCP pool

room-8switch1(config-if)#ip address z.z.z.z 255.255.254.0
room-8switch1(config-if)# end

room-8switch1(config)#ip default-gateway z.z.z.1
room-8switch1(config)# end

room-8switch1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
Compressed configuration from 4128 bytes to 1591 bytes[OK]
 # ---- VLAN Work 

See VLAN Trunk Protocol (VTP)
room-8switch1# show vtp status 
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 74a0.2f8e.37c0
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Feature VLAN:
--------------
VTP Operating Mode                : Transparent
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 5
Configuration Revision            : 0
MD5 digest                        : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
                                    0x56 0x9D 0x4A 0x3E 0xA5 0x69 0x35 0xBC

See current VLANs.
room-8switch1# show vlan 
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/1, Gi1/2, Gi1/3, Gi1/4
                                                Gi1/5, Gi1/6, Gi1/7, Gi1/8
                                                Gi1/9, Gi1/10, Gi1/11, Gi1/12
                                                Gi1/13, Gi1/14, Gi1/15, Gi1/16
                                                Gi1/17, Gi1/18, Gi1/19, Gi1/20
                                                Gi1/21, Gi1/22, Gi1/23, Gi1/24
                                                Gi1/25, Gi1/26, Gi1/27, Gi1/28
                                                Gi1/29, Gi1/30, Gi1/31, Gi1/32
                                                Gi1/33, Gi1/34, Gi1/35, Gi1/36
                                                Gi1/37, Gi1/38, Gi1/39, Gi1/40
                                                Gi1/41, Gi1/42, Gi1/43, Gi1/44
                                                Gi1/45, Gi1/46, Gi1/47, Gi1/48
                                                Te1/49, Te1/50, Te1/51, Te1/52
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Look at VLAN database file.
room-8switch1# dir cat4000_flash: 
Directory of cat4000_flash:/
    1  -rw-         556                 <no date>  vlan.dat
524284 bytes total (523728 bytes free)

Create 2 VLANs, configure port to access a VLAN on individual and range of interfaces.
room-8switch1# config t 
Enter configuration commands, one per line.  End with CNTL/Z.
room-8switch1(config)#vlan 321 
room-8switch1(config)#vlan 322

room-8switch1(config)#interface GigabitEthernet 1/24
room-8switch1(config-if)#switchport access vlan 321
room-8switch1(config-if)#exit

room-8switch1(config)#interface GigabitEthernet 1/35
room-8switch1(config-if)#switchport access vlan 322
room-8switch1(config-if)#exit

room-8switch1(config)#interface range GigabitEthernet 1/24-44
room-8switch1(config-if-range)#switchport mode access
room-8switch1(config-if-range)#exit
room-8switch1#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/1, Gi1/2, Gi1/3, Gi1/4
                                                Gi1/5, Gi1/6, Gi1/7, Gi1/8
                                                Gi1/9, Gi1/10, Gi1/11, Gi1/12
                                                Gi1/13, Gi1/14, Gi1/15, Gi1/16
                                                Gi1/17, Gi1/18, Gi1/19, Gi1/20
                                                Gi1/21, Gi1/22, Gi1/47, Gi1/48
                                                Te1/49, Te1/50, Te1/51, Te1/52
321  VLAN0321                         active    Gi1/24, Gi1/26, Gi1/28, Gi1/30
                                                Gi1/32, Gi1/34, Gi1/36, Gi1/38
                                                Gi1/40, Gi1/42, Gi1/44
322  VLAN0322                         active    Gi1/23, Gi1/25, Gi1/27, Gi1/29
                                                Gi1/31, Gi1/33, Gi1/35, Gi1/37
                                                Gi1/39, Gi1/41, Gi1/43, Gi1/45
                                                Gi1/46

Create uplink to Cisco NX-OS n3000, Software (n3000-uk9), Version 6.0(2)U3(1)

This switch has six 40G ports. There is an option of connecting one 40G port to four 10G ports by using a 40G QSFP to four 10G SFP+ Optics Cable. This cable is okay for distance up to 10m.
n3000-swi# show interface brief
..
Eth1/49/1     1       eth  trunk  up      none                        10G(D) --
Eth1/49/2     1       eth  trunk  down    Administratively down       10G(D) --
Eth1/49/3     1       eth  trunk  up      none                        10G(D) --
Eth1/49/4     1       eth  trunk  up      none                        10G(D) --
Eth1/50/1     1       eth  trunk  up      none                        10G(D) --
Eth1/50/2     1       eth  trunk  up      none                        10G(D) --
Eth1/50/3     1       eth  trunk  up      none                        10G(D) -- downlink to Catalyst 4948E-F 
Eth1/50/4     1       eth  trunk  up      none                        10G(D) --
Eth1/51/1     1       eth  trunk  up      none                        10G(D) --
Eth1/51/2     1       eth  access down    Administratively down       10G(D) --
Eth1/51/3     1       eth  access down    Administratively down       10G(D) --
Eth1/51/4     1       eth  access down    Administratively down       10G(D) --
Eth1/52       1       eth  trunk  up      none                        40G(D) --
Eth1/53       1       eth  trunk  up      none                        40G(D) 1
Eth1/54       1       eth  trunk  up      none                        40G(D) 1

Here we user Cisco 40G QSFP to Four SFP+ Breakout Active Optics Cable. The 40G is connected to NEXUS port 50 and then cable splits to 4 "smaller" cables each has 10G connection to four downlink switches.
interface Ethernet1/50/1
  description downlink to switch-5
  switchport mode trunk
  switchport trunk allowed vlan 321-322,555
  speed 10000
  no shutdown

interface Ethernet1/50/2
  description downlink to switch6
  switchport mode trunk
  switchport trunk allowed vlan 321-322,666
  no shutdown

interface Ethernet1/50/3     
  description downlink to downlink to Catalyst 4948E-F
  switchport mode trunk
  switchport trunk allowed vlan 321-322
  no shutdown

interface Ethernet1/50/4
  description downlink to switch-7
  switchport mode trunk
  switchport trunk allowed vlan 321-322
  no shutdown
# show interface Ethernet1/50/3 
Ethernet1/50/3 is up
 Dedicated Interface
  Hardware: 1000/10000 Ethernet, address: 4c00.82fe.127e (bia 4c00.82fe.127e)
  Description: downlink to Catalyst 4948E-F
  MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 10 Gb/s, media type is 40G
  Beacon is turned off
  Input flow-control is off, output flow-control is off
  Rate mode is dedicated
  Switchport monitor is off
  EtherType is 0x8100
  Last link flapped 21:53:28
  Last clearing of "show interface" counters 20w2d
  1 interface resets
  30 seconds input rate 80 bits/sec, 0 packets/sec
  30 seconds output rate 9824 bits/sec, 10 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 80 bps, 0 pps; output rate 9.01 Kbps, 8 pps
  RX
    0 unicast packets  3955 multicast packets  0 broadcast packets
    3956 input packets  809782 bytes
    0 jumbo packets  0 storm suppression packets
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    4848 unicast packets  769644 multicast packets  173160 broadcast packets
    947652 output packets  95789923 bytes
    241 jumbo packets
    0 output errors  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble 0 output discard
    0 Tx pause

# show interface Ethernet1/50/3 brief 
--------------------------------------------------------------------------------
Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port
Interface                                                                   Ch #
--------------------------------------------------------------------------------
Eth1/50/3     1       eth  trunk  up      none                        10G(D) --

# show interface status | begin 1/50 
Eth1/50/1  downlink to switch-5         connected trunk     full    10G     QSFP-4X10G-AOC7 # shows 7m
Eth1/50/2  downlink to switch6          connected trunk     full    10G     QSFP-4X10G-AOC7
Eth1/50/3  downlink to Catalyst 4948E-F connected trunk     full    10G     QSFP-4X10G-AOC7
Eth1/50/4  downlink to switch-7         connected trunk     full    10G     QSFP-4X10G-AOC7
Eth1/51/1  downlink to xxx              connected trunk     full    10G     QSFP-4X10G-AOC5 # shows 5m
Eth1/51/2  --                           disabled  1         full    10G     QSFP-4X10G-AOC5
Eth1/51/3  --                           disabled  1         full    10G     QSFP-4X10G-AOC5
Eth1/51/4  --                           disabled  1         full    10G     QSFP-4X10G-AOC5 
Eth1/52    downlink to zzz              connected trunk     full    40G     QSFP-H40G-AOC2M #shows 2m
Eth1/53    --                           connected trunk     full    40G     QSFP-H40G-AOC10 #shows 10m
Eth1/54    --                           connected trunk     full    40G     QSFP-H40G-AOC10
Back to the main page